Identificarse | Registrarse | FAQ
Anonymous

problemas con iframes en chrome

+ Publicar una respuesta

3 mensajes Página 1 de 1


problemas con iframes en chrome

por BugsBunny » Jue Abr 11, 2013 12:12 am

buenas tardes, pues aqui con otra molestia.
El siguiente codigo funciona bien con firefox pero no con chrome. PORQUE????

codigo del index (parent):
Código: Seleccionar todo
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
   <title>Prueba de IFrame</title>
   <meta http-equiv="content-type" content="text/html; charset=utf-8" />
   <script src="jquery-1.9.1.js"></script>
   <script>
      $(function(){
         $(".boton").click(function(){
            var mas="<iframe src='frame.html' bordercolor='red' frameborder='1'></iframe>";
            $('.despliega').append(mas);
         });
         $(".boton1").click(function(){
            $('.despliega').html("");
         });   
      });
   </script>
</head>

<body bgcolor="#0000FF" text="#FFFFFF">
   <h1>ejemplo de iframe</h1>
   <span class="boton">Click aqui para que aparezca el iframe</span><br />
   0<br />
   <span class="boton1">Click aqui para que desaparezca el iframe</span><br />
   <div class="despliega"></div>
   <h2>Aqui va otro texto</h2>
   esto es lo que recibi del iframe:
   <div id="guarda" style="color:#FF0000"></div>   
</body>
</html>


codigo del iframe:
Código: Seleccionar todo
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
   <title></title>
   <meta http-equiv="content-type" content="text/html; charset=utf-8" />
   <SCRIPT LANGUAGE=JavaScript>
      function manda(valor)
      {
         parent.document.getElementById("guarda").innerHTML = valor;
      }
   </SCRIPT>
</head>
<body bgcolor="#00FF00">
   <h1>Este es el iframe</h1>
   <table border="3px" bordercolor="#FF0000">
      <tr>
         <td onClick="manda('uno')">uno</td>
         <td>valor 1</td>
      </tr>
      <tr>
         <td onclick="manda('dos')">dos</td>
         <td>valor 2</td>
      </tr>
      <tr>
         <td onclick="manda('tres')">tres</td>
         <td>valor 3</td>
      </tr>
      <tr>
         <td onclick="manda('cuatro')">cuatro</td>
         <td>valor 4</td>
      </tr>
   </table>
</body>
</html>


gracias por su atencion, y espero me puedan ayudar.
Avatar de Usuario

BugsBunny

  • Mensajes: 22
  • Registrado: Sab Nov 10, 2012 6:25 am

Re: problemas con iframes en chrome

por BugsBunny » Jue Abr 11, 2013 2:20 am

buscando otras opciones, encontre que tambien se puede utilizar ajax para hacer esto, baje un ejemplo, pero al ejecutarlo en chrome no funciona pero si en firefox, que pasa? necesita chrome alguna configuracion especial?
Avatar de Usuario

BugsBunny

  • Mensajes: 22
  • Registrado: Sab Nov 10, 2012 6:25 am

Re: problemas con iframes en chrome

por BugsBunny » Jue Abr 11, 2013 2:39 am

se ha resuelto el problema, YUUUUUPIIIII!!!
perdon pero es que me hizo sufrir este problema.

la solucion?

no se porque pero chrome necesita tener instalado un servidor y cargar tu pagina con localhost/iframe, firefox no lo necesita.

espero les sirva esta solucion.

la unica duda es: que es mejor, usar iframe o ajax.
Avatar de Usuario

BugsBunny

  • Mensajes: 22
  • Registrado: Sab Nov 10, 2012 6:25 am


+ Publicar una respuesta

Página 1 de 1